See Official Sweepstakes Rules here.
cancel
Showing results for 
Search instead for 
Did you mean: 

ProSupport

DrewArmstrong
Mover & Shaker

I am deep into Sony... And this past August I dropped my Sony A1 right on the hot shoe with the 200-600mm lens on. The camera looked fine... until you looked through the view finder and found the viewfinder was cracked right in half. It took about 5 weeks to get fixed even being a Pro Support member.  

Here is the thing. I use my camera all the time. And paid for my ProSupport membership for years to come by getting a loaner camera from ProSupport. You should get it. 

This being said, I have the best laptop apple makes... really. And I cannot get my lenses that need to have firmware updates to work with my new A7r5 to update. So, I called prosupport tonight Waited on hold for 30 minutes. And, the "you can start a conversation via text with a support person for pressing 1) feature did not work. I actually get an error message and am told to reach out later. I really want to be shooting birds in the morning... later... Rather than getting the issue taken care of now. 

3 REPLIES 3

Drew_Geraci
Leading Creator

Hey Drew,

I totally feel you on the updating side of things with the lens firmware, or firmware's in general. You may want to honestly invest in a very cheap PC because that will honestly give you the best experience for updating firmware (since the coding doesn't change) as it's not Sony's direct fault that updates can be difficult on a Mac. Apple changes its coding language quite frequently with each OS update which is why MANY programs often take a while to be re-coded or modified so they work well on newer Macs (especially with Apple Silicone). 



LensBrew
Prime Creator

I don't believe Mac is the issue. I have one (M1 with latest OS) and used it to update 3 of my lenses with the new updates last month. I didn't have an issue and successfully update them using a7r4. There might previous version of the update driver that is causing this, or the a7r5 is not set to update the lenses yet. Usually it's trial and error to find the problem. But try updating on the A1, if it works then there might be something in the a7r5. 

Another problem, and it says it on some of the warnings, you would not be able to install the latest firmware if there is more than 1 update in between. Actually some might not have that restriction, but some definitely do.

CuriousBirder
Star Member

Did you use the 24/7 number? Do the files transfer to the A7R5 or do you get error codes? I know this isn't a fix, but do you have any friends willing to let you use their laptop/computer to transfer? Do you have any issue with accessing your photos with the A7R5 when it is attached to your laptop? I had issue with one of the USB cables and had to go usb c to usb c to get it to work. From what a rep told me, the update on the 200-600 was mainly video related. Shooting with a A7R5 and tracking is great, but produced mixed images. It may just be me trying to figure out the settings. Will be shooting with a 100-400 GM lens to compare.